It seems like everyone likes puzzles, so I thought I would make one.
The diagram below indicates a network where users on router 1 connect to the servers on router 2 via a transport network.
Router 1 and Router 2 had an EIGRP neighbor adjacency using EIGRP and everything was working fine, however, in an effort to move to open standards a similar configuration with OSPF was implemented. Now, tunnel 0 will not stay up.
The current configurations for R1 and R2 are below.
!!!R1
!
hostname R1
!
!
logging buffered 4096 informational
!
interface Tunnel0
description ***TUNNEL TO R2***
ip address 172.18.1.1 255.255.255.252
tunnel source Loopback0
tunnel destination 12.43.78.141
!
interface Loopback0
ip address 12.43.78.129 255.255.255.252
!
interface FastEthernet0/0
description ***USER NETWORK***
ip address 172.17.51.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ***TRANSPORT LINK1***
ip address 12.43.78.122 255.255.255.252
clock rate 2000000
!
!
interface Serial0/1
description ***TRANSPORT LINK2***
ip address 12.43.78.126 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0 0.255.255.255 area 0
network 172.16.0.0 0.15.255.255 area 0
!
ip route 12.43.78.140 255.255.255.252 12.43.78.121 name R2_LOOPBACK_NETWORK
ip route 12.43.78.140 255.255.255.252 12.43.78.125 2 name R2_LOOPBACK_NETWORK
!!R2
!
hostname R2
!
!
logging buffered 4096 informational
!
interface Tunnel0
description ***TUNNEL TO R1***
ip address 172.18.1.2 255.255.255.252
tunnel source Loopback0
tunnel destination 12.43.78.129
!
interface Loopback0
ip address 12.43.78.141 255.255.255.252
!
interface FastEthernet0/0
description ***SERVER NETWORK***
ip address 172.17.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ***TRANSPORT LINK1***
ip address 12.43.78.134 255.255.255.252
clock rate 2000000
!
!
interface Serial0/1
description ***TRANSPORT LINK2***
ip address 12.43.78.138 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0 0.255.255.255 area 0
network 172.16.0.0 0.15.255.255 area 0
!
ip route 12.43.78.128 255.255.255.252 12.43.78.133 name R1_LOOPBACK_NETWORK
ip route 12.43.78.128 255.255.255.252 12.43.78.137 2 name R1_LOOPBACK_NETWORK
The EIGRP configuration that was working is below.
!old eigrp section
router eigrp 1
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0
network 172.16.0.0 255.240.0.0
no auto-summary
Additionally, the routers can easily ping each other via their loopback addresses that are used for the tunnels.
R1#ping 12.43.78.141 source 12.43.78.129
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.43.78.141, timeout is 2 seconds:
Packet sent with a source address of 12.43.78.129
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/43/76 ms
Why did this tunnel start failing when OSPF was introduced? What can be done to fix the issue?
The diagram below indicates a network where users on router 1 connect to the servers on router 2 via a transport network.
Router 1 and Router 2 had an EIGRP neighbor adjacency using EIGRP and everything was working fine, however, in an effort to move to open standards a similar configuration with OSPF was implemented. Now, tunnel 0 will not stay up.
The current configurations for R1 and R2 are below.
!!!R1
!
hostname R1
!
!
logging buffered 4096 informational
!
interface Tunnel0
description ***TUNNEL TO R2***
ip address 172.18.1.1 255.255.255.252
tunnel source Loopback0
tunnel destination 12.43.78.141
!
interface Loopback0
ip address 12.43.78.129 255.255.255.252
!
interface FastEthernet0/0
description ***USER NETWORK***
ip address 172.17.51.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ***TRANSPORT LINK1***
ip address 12.43.78.122 255.255.255.252
clock rate 2000000
!
!
interface Serial0/1
description ***TRANSPORT LINK2***
ip address 12.43.78.126 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0 0.255.255.255 area 0
network 172.16.0.0 0.15.255.255 area 0
!
ip route 12.43.78.140 255.255.255.252 12.43.78.121 name R2_LOOPBACK_NETWORK
ip route 12.43.78.140 255.255.255.252 12.43.78.125 2 name R2_LOOPBACK_NETWORK
!!R2
!
hostname R2
!
!
logging buffered 4096 informational
!
interface Tunnel0
description ***TUNNEL TO R1***
ip address 172.18.1.2 255.255.255.252
tunnel source Loopback0
tunnel destination 12.43.78.129
!
interface Loopback0
ip address 12.43.78.141 255.255.255.252
!
interface FastEthernet0/0
description ***SERVER NETWORK***
ip address 172.17.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ***TRANSPORT LINK1***
ip address 12.43.78.134 255.255.255.252
clock rate 2000000
!
!
interface Serial0/1
description ***TRANSPORT LINK2***
ip address 12.43.78.138 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0 0.255.255.255 area 0
network 172.16.0.0 0.15.255.255 area 0
!
ip route 12.43.78.128 255.255.255.252 12.43.78.133 name R1_LOOPBACK_NETWORK
ip route 12.43.78.128 255.255.255.252 12.43.78.137 2 name R1_LOOPBACK_NETWORK
The EIGRP configuration that was working is below.
!old eigrp section
router eigrp 1
passive-interface default
no passive-interface Tunnel0
network 12.0.0.0
network 172.16.0.0 255.240.0.0
no auto-summary
R1#ping 12.43.78.141 source 12.43.78.129
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.43.78.141, timeout is 2 seconds:
Packet sent with a source address of 12.43.78.129
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/43/76 ms
Why did this tunnel start failing when OSPF was introduced? What can be done to fix the issue?
http://ephemeralportal.blogspot.jp/2014/02/answer-to-puzzle-1.html
ReplyDeleteSpade Vision on T-Shirt - T-Shirt - Titanium - T-Shirt
ReplyDeleteA unique T-Shirt titanium dental implants and periodontics designed by T-Shirt created by T-Shirt. This unique T-Shirt is tube supplier created titanium piercings for all titanium frames ages to nano titanium enjoy. We offer a unique unique T-Shirt designed by T-Shirt $19.99 · In stock